Oct 292013
 
5.00 avg. rating (100% score) - 3 votes

When I was upgrading my WordPress 3.6.1 to 3.7 I came across below warning when trying to Upgrade Network:

Warning! Problem updating https://SITENAME. Your server may not be able to connect to sites running on it. Error message: SSL certificate problem: self signed certificate in certificate chain.

Luckily came across post from o6asan which put me on right track on fixing the issue. Basically in wp-includes directory there is another directory certificates which contains file ca-bundle.crt. This file is simply a text file/library (in PEM format) containing public certificates of different CA(s), of course some of them are missing.

To work around my issue, since CAcert.org from which my certificates are was not included, I just added their root certificates (Class 1 PKI Key, Class 3 PKI Key) and was no loner seeing above warning.

  7 Responses to “Error upgrading WordPress (SSL)”

  1. Hi, Oiram!!

    Have you had the same issue, yet? I have not used your workaround, and I still use my private CA as before.
    However, in my case, I feel 3.7.1. seems to solve the issue though I don’t confirm whether it’s true or not.

    How about your case?

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)